45
bryukh
16 32 48
15857/ 17173
Valentin Bryukhanov http://bryukh.com/
Last seen 2 years ago
Member for 11 years, 8 months, 2 days
Difficulty Normal
Developer, engineer and taskMaker.

Best reviews / Newest reviews
LIB 004 The Most Numbers-Grimtyler 1 1
> round(diff,4) This is not necessary More
First-zaneli 1 1
Why? result_v = check_vertical(matrix) if result_v: return True It can be shorter and simpler: if check_vertical(matrix): return True Or you can simplify the whole function: return check_vertical(matrix) or check_horizontal or check_diagonal More
First-jcg 1
Good solution. But be careful with variables names as **"o"** (also as **"l"**). It can be read as 0 for some fonts. For humans vision :-) More
min_enum_sum-dronnix 1 1
You can transpose matrix with a simple trick -- zip(*matrix). More
Dynamic Selection-PositronicLlama 1
Super! I like selection of algorithm. More
First-htamas 1
Thanks. This is the original solution and interesting method with rotations. It's something new. More
First-Sim0000 1 1
Great. But variables names are not descriptive. More
Ugly bruteforce-Amachua 1 1
Yeah, the third loop is redundant even for bruteforce :) More
First-Bibiche 1
Nice code! Not neccessary place your functions inside checkio function. Its can be outside. More
Cheating :)-weerd 1 1
Ha ha :) Super! It's really funny. You just made my day. More
First-ForrestGump 1
line 4-7 can be simpler if alpha not in text: return False More
First-eugen.stegnij 1
I didn't get why do you use "*a" here. A input tuple become a == ((data),) and then you unwrap it again. list conversion are redundant -- "sorted" can work with tuples too. And "lambda x: abs(x)" is the same as "abs". So you can use "key=abs". P.S. PEP8 is a good choice for "Clear" ca More
First-coells 1
This is a surprise solution. Great! More
First-tuxninja 1
You don't need line 2. Just `def checkio(number):` if you don't like 'data' name. More
Comprehend-veky 1 1
It's real short! But too slow. Yes, you are lazier than i am :) More
Solution for anything Class-based.-diegueus9 1
Simple and clear. And a good idea about "call". Nothing to add :-) More
Friends - too many strings, but it's mine)-AleksandrKasianov 1 1
"self.connection = connection" is redundant in "add" or "remove" methods. You don't need save them in the instance. line 7 if isinstance(self.connections,tuple): Why do you check it in "add" method? You save "connection**S**" in init. If you are using "if self.connection in to_list_connectio More
pbs-veky 1 1
At first look i thought "This is not a puzzle. I see indents and docstring. It's clear solution and Veky didn't write it" :) But then... You broke my brain. Now i have the puzzle for weekend. More
Slice-PositronicLlama 1 1
"all" is a builtin name, so this is a bad choice. More
First-jcg 1
Thank you for the interesting comments. More
1
2
3 4 5 6 7 8