57
veky
22 48 64 Leader of the month
44676/ 53887
Last seen 21 hours ago
Member for 11 years, 6 months, 24 days
Difficulty Advanced
We shall not cease from exploration, and the end of all our exploring will be to arrive where we started and know the place for the first time.

Best reviews / Newest reviews
First-Sim0000 1
Line 8 is the most important one. :-D More
Too eager ;-)-veky 1 1
Why is '00:45' not a problem for .lstrip('0')? ;-) More
FP & MetaOOP-flpo 1
Flat is better than nested, indeed. :-D The only thing you missed is that you could write line 25 as cube_volume = 3..__rpow__ :-D More
Simple-Taca 1
You were very close with that "key". ;-) return max(sorted(map), key=map.count) Also, you don't need re. You can just use "abcdefghijklmnopqrstuvwxyz" (also known as string.ascii_lowercase) as first argument to max, and key=text.count as second. But then it's too easy. :-D More
try except-Phil15 1 1
Wouldn't it be clearer if you factored that duplication out? More
Complex numbers for x,y position-JamesArruda 1
Yes, of course complex numbers are a natural representation of 2D. But you can go _much_ further. For example, instead of dirs[dir_idx], you can just use (-1j)**dir_idx. The set of complex numbers is not just 2D vector space, it's also a field. ;-) More
Weird, I managed to make it work-livingdead 1 1
You also managed to overcomplicate it. :-D More
Simplified stack solution-bsquare 1 1
Now, isn't that much better? B-) More
With itertools batteries: chain, repeat, starmap-flpo 1
Those Lego bricks really fit into one another. :-D More
Dumb Vampire-obone 1 1
Deque might be better as an underlying type for the Army. More
The Better Solution-obone 1
"Improvement" depends on the criteria. I surely think that just trying the bases until one works is more intuitive than calculating the maximal digit value --- but of course, the second one is faster. More
No for loop-tralfamafnord 1 1
... but def loop. :-) Nice. Though you didn't really need another function... checkio could be called recursively. :^) More
WET-veky 1
This code has an enormous amount of duplication. But removing all the duplication would make the code twice longer. ;-) More
Strip Teasing-caldeius 1
That's how I planned to call my solution, bit there might be children around. 😛 More
No imports!-vby 1 1
Not a bad idea, but can be much better done. Instead of heaviside you can simply use bool, but if you want another function, a better idea is to eliminate the duplication for hours and minutes. Something like pluralize(hours, 'hour') and pluralize(minutes, 'minute'). Or even count('hours') and count More
len(set(ratio_sides)) ==1-Olpag 1
Instead of comment, use a less misleading name. More
scan circle perimeters with variable step-ayubutrym 1
Nice adaptive algorithm, but you're doing one thing wrong: when using tau, never say 2*pi in the comments. If you are True Believer in Tau, then you know it is more elementary than pi. If you feel you must "explain", use "turn" or "full turn". ;-) More
test corners & split undecided-juestr 1 1
Very nice approach! Is this exact (up to the float inexactness)? I think it is. More
write on screen-kurosawa4434 1
This one is the most similar to mine, I guess. But still a bit more complicated. :-) More
First-Kurush 1
Yes. You're just missing a bit of math, and a thorough knowledge of the standard library. :-) More