57
veky
22 48 64 Leader of the month
44583/ 53887
Last seen 16 hours ago
Member for 11 years, 6 months, 6 days
Difficulty Advanced
We shall not cease from exploration, and the end of all our exploring will be to arrive where we started and know the place for the first time.

Best reviews / Newest reviews
First-blabaster
Argh. Those explicit slices are really unpythonic. Please use split. Also, see dict.setdefault. ;-) More
Two Counters-veky 1
Inspired by algorithmically beautiful and Pythonically ugly @quiath's [solution](http://www.checkio.org/mission/the-square-chest/publications/quiath/python-3/nice-and-simple/?ordering=most_voted). There is only _one_ place where 4 is mentioned in the code, and changing it enables the algorithm to w More
First-blueBlood
Lines 2-5: do you know what "precondition" means? :-/ Line 6: data.sort() is more readable and faster. Line 11: I don't get why you float m. Of course you don't need to. Lines 15-19: This is really head-scratching. Why do you do such contortions?? More
First-blueBlood 1
That inner while loop, with explicit x management, is unnecessary. for letter, lnext in zip(word, word[1:]): (you might want to end the zip earlier if your snake is too young:). More
ghost-blueBlood
Lines 25 and 26 are just: return age == x + y More
First-blueBlood 1
First, it's not advisable to change (line 39) a dict iterated through (line 33). Second, why line 42? If not x, then surely second not in x. :-) More
First-vananabu
Argh, famous [FOR-CASE paradigm](https://en.wikipedia.org/wiki/Loop-switch_sequence). :-O More
First-monica 1
This really made me laugh. Especially that everything is named "digit". :-D More
First-monica
Please use // instead of int(.../...). Also, that len(list) // 2 could be named some nice name. ;-) More
First-monica
Nice and obvious. Could be list comprehension, but not needed. More
First-monica
Lines 11~15: Please learn about tuple comparisons. They are really helpful here. (a, b) < (c, d) means exactly a < c or a == c and b < d. More
First-monica
sum being a builtin means you should use it as a builtin, not redefine it. :-) Also, please iterate through sequence, not indices. Learn about slices if you need only some indices. More
First-monica
Nice and obvious. Hint: you don't need line 4, "for word in words.split()" would work just as nicely (.split would be evaluated only once:). More
First-monica
list, max and min are builtins. Hint, hint. ;-) More
First-monica
Also could be generator expression (with any), but this is nice too. More
First-monica
OK, but you might want to learn about sets and & (intersection) operator. Faster and cleaner than rolling your own. More
First-monica
That's the way (aha, aha) I like it (aha, aha). :-D More
First-monica
Also obvious. You could check for divisibility by lcm(3,5)=15 in line 12. :-) More
First-gyahun_dash 1
The most pointless use of yield from. :-) BTW, line 7 could probably be array.pop(argmax). At least if you say array = list(initial) in line 2. More
First-therin
Local function could help. See my solution. ;-) More