57
veky
22 48 64 Leader of the month
44584/ 53887
Last seen 23 hours ago
Member for 11 years, 6 months, 7 days
Difficulty Advanced
We shall not cease from exploration, and the end of all our exploring will be to arrive where we started and know the place for the first time.

Best reviews / Newest reviews
quite comprehensive-Czarinov 1
Horrible. :-P First, why those empty lines? They don't increase readability, especially since one of lines is too long. sum([... for ...]) ~~~> sum(... for ...) Just drop the []. Generator expressions are nicer, clearer, faster, and use less memory. And you surely don't need list compr More
First-cbrunet
Nice algo. A few Pythonic nitpickings: * It would be nicer if tuples in q were (time, pos,...), then you could just sort them directly by time. Or if you want to be explicit, you could have used namedtuple. * q.pop(0) is slow with no good reason to use it. It would be better to q.sort(reverse=True More
158-DiZ 1
Hehe... mine is almost as short, and I didn't even try to golf. :-) More
First-cwahbong
It always bugged me why people import the wrong thing from collections. :-) Counter is obviously more specific, and precisely what you need. And don't map literal lambdas, especially of one variable. You get precisely nothing. sum(map(lambda arg: expr, seq)) ~~~> sum(expr for arg in seq) More
Simple to understand not fancy or efficent-KleinerNull
Not fancy or efficient, I agree. Simple to understand... well. Horrible duplications, indexing instead of unpacking and naming things, superfluous constructs, unnecessary rebindings... and to top it all off, if adict.get(key, False): :-O Even Py2 should have `key in adict` construct by now. More
Et tu, Brute Force?-veky
Inspired by [bukebuer](http://www.checkio.org/mission/network-loops/publications/bukebuer/python-27/second/?ordering=most_voted) (and Guido;). More
recursive-ciel
`a = max(a, incredibly_long_name, key=len)` is cool, but every time incredibly_long_name doesn't give something longer than a, Python "rebinds" a to itself. Maybe it would be better after all to use if? b = incredibly_long_name if len(b) > len(a): a = b More
unicodedata FTW-Faibbus
But you should use it fully FTW. :-P Check out unicodedata.category and unicodedata.combining. ;-) More
Golf!-blabaster
I'd still like to register my general dislike of eval, but here it's overweighted by elegance of this solution. Congratulations, you win one of Veky's fives! :-) And yes, I find it funny that you call it golf, and then use spaces as is proper. :-) As if you're saying, "this is _so_ short, I can spr More
UGLY : When Coffee Is not an Option-robby.daigle
Lines 16~18: how about if s[-2]: ? :-) More
First-xiaozhan 1
words.split() would probably be better. Also, spaces. num += 1 and num = 0 are really much clearer, especially since you wrote it that way in line 2. More
First-smilicic
Yaaawn. :-P At least you reused area in volume. :-) More
eval-tsuro
Nice. Even I didn't know implicit concat works without space. :-) More
Python haiku-hrvoje
As I told you, look at [bunnychai](http://www.checkio.org/mission/how-much-gold/publications/bunnychai/python-27/first/?ordering=most_voted). ;-) More
First-gflegar
So, how do you feel after reinventing ~~the wheel~~ namedtuple? :-D More
And around, and around, and around and around we go.-hrvoje
You see, generators aren't so hard. :-) Though, you don't need i. You can use _, or simply range(len(a)). More
Nom nom nom nom-hrvoje
Too many abses there. .-P And Fraction(1) would be enough. More
Bool overdose-hrvoje
Real overdose. In what way is `bool(i<0)` better than just `i<0`? Do you also write `float(3.5)` or `list([2,8])`? Also, eval takes another argument, you don't need to replace. :-) More
First-vkastala
Missing/nonmissing spaces make this code ugly at a first sight. "curage" is probably misnamed, should be "current_opacity", right? Also, your fib generator is too complicated. Use tuple assignment for great good. :-) def fibgen(): a, b = 0, 1 while b < 5e3: a, b = b More
First-ILQU 1
Your code has a weird mix of using //2, /2 and /2.0. (That's probably the consequence of using Py2.:) Either stay with Py2 (without `from __future__ import division`), use `/2` and `/2.0`, or (much better;) switch to Py3, where you use `//2` and `/2`. Also, length should be properly spelled. Or jus More